Issue with subscriptions

Incident Report for Plugsurfing Power Platform

Resolved

Temporary Issue with Subscription Sign-ups
Resolved: Yes
Impact Period: 21st May 2025, from 11:30 to 14:30 CET

Impact: A subset of users (61) were unable to complete subscription sign-ups due to an internal system error.

What happened:
A recent update introduced a change that inadvertently caused some subscription requests to be processed incorrectly. This resulted in failures during the subscription creation process.

What we’ve done:
We identified the issue quickly and rolled back the affected component to a previous stable version. Subscription functionality has been fully restored.

Next steps:
We are taking measures to prevent this type of issue in the future, including improving automated testing for API changes and enforcing stricter validation of request formats.

We sincerely apologize for the inconvenience and thank you for your patience.
Posted May 21, 2025 - 12:30 UTC

Investigating

A subset of users (~60) were unable to complete subscription sign-ups due to an internal system error.
Posted May 21, 2025 - 09:30 UTC
This incident affected: Drive API, Mobile Apps, and Driver Web Portal.