Performance degradation and disruption in Plugsurfing Apps and Services

Incident Report for Plugsurfing Power Platform

Resolved

Dear Customers,

We want to keep you informed about the minor incident which degraded performance of our apps and services. Our dedicated team has monitored and applied some minor infrastructure changes to resolve it.

Impact: Some drivers might have experienced slowness and performance impact on the mobile app
What was not impacted: Ongoing charging was not impacted. The drivers charging on our network using a physical key card were not impacted.
Resolution: Updated some settings in our infrastructure to resolve the performance degradation in our services.
Incident duration: 16.30 CET - 19:15 CET

With the successful resolution of the incident, all affected services have been fully restored to their normal functioning state. We appreciate your patience and understanding during this time.

We look forward to serving you with excellence. Should you have any further questions or require additional information, please do not hesitate to contact us.

Best regards,
Plugsurfing team
Posted Sep 12, 2025 - 17:45 UTC

Investigating

Dear Customers,

We are currently experiencing service disruption and slowness with our mobile app and web portals.

Impact: Some drivers might not be able to use the mobile app for some features or will experience slowness.
What is not impacted ongoing charging is not impacted. This is not impacting the drivers charging on our network using a physical key card.
Start Time: 16.30 CET
Status: Investigating

Our engineering team is working to identify the root cause and implement a fix. We understand the importance of our services to your business operations, and we deeply apologize for any inconvenience this may cause. If you have any urgent concerns or require additional information, please do not hesitate to contact our customer support team.

We will send an additional update as soon as we
Posted Sep 12, 2025 - 15:45 UTC
This incident affected: Mobile Apps and Driver Web Portal.