Verification is currently underway for the maintenance items.
Posted Feb 11, 2026 - 05:56 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 11, 2026 - 05:00 UTC
Scheduled
Dear Customers,
We would like to inform you about a planned maintenance window where you could experience some disruptions while using Plugsurfing services.
Maintenance Window: Date: Wednesday, 11 Feb 2026 Time: 06:00 AM – 08:00 AM CET
During this time, one could experience disruptions in remote charging, location push and location pull. Our team will work to minimize disruptions and ensure normal operations resume promptly.
We sincerely apologize for any inconvenience and thank you for your patience. For urgent assistance, contact our Customer Support.
Best regards, The Plugsurfing Team
Posted Feb 04, 2026 - 15:38 UTC
This scheduled maintenance affected: P3 Web Portal and Roam OCPI.