Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 19, 2025 - 04:30 UTC
Scheduled
Dear Customers,
We would like to inform you about a scheduled maintenance on some components of our platform that may temporarily impact some customers using Plugsurfing products and applications.
Maintenance Window: Date: 19th September 2025 Time: 06:30 - 07:00 CET
During this time, some customers may encounter brief service disruptions. Our team will strive to minimise the downtime and ensure services are restored as quickly as possible.
We apologize for any inconvenience this may cause and appreciate your understanding. For any questions or further assistance, please feel free to reach out to our customer service team.
Thank you for your cooperation.
Best regards, Plugsurfing Team
Posted Sep 12, 2025 - 12:57 UTC
This scheduled maintenance affected: P3 Web Portal, Drive API, Mobile Apps, and Driver Web Portal.